Resolution of N588XL FADEC Issues

Discussion off all the ADs.
Post Reply
User avatar
Posts: 341
Joined: Sun Jun 08, 2008 3:12 pm
Tail Number: N588XL
Certificates Held: Commercial-SEL / Instrument Airplane

Resolution of N588XL FADEC Issues


Here is the full story behind my 6+ week downtime in Hyannis due to FADEC issues. This is input here for your future reference and knowledge if you have similar issues.
The end cause was BOTH ECU's channel A going bad. Once we replaced BOTH ECU's and made a few other fixes the issue was solved. This is a detailed chronology of my other earlier post. One word of caution owners...the right (lower left) ignition switch contact is very close to another empty contact. If the instrument panel is replaced carelessly back...the right ignition switch contact can rotate and ground out on the neighboring contact. A simple fix is to put a dab of RTV between the contacts to prevent this from ever occurring. It may have contributed to my ECU failures. It can commonly occur when someone who does the bi-annual Pitoh checks is careless when reinstalling the instrument panel.
Summary of Liberty N588Xl FADEC Issues March 2014

On Friday March 7, after preheating the engine I started up the engine and performed a run up. The engine ran fine and no abnormal readings or FADEC illuminations occurred. I then departed KBDR and about 5 miles from the airport while leveling off at 3000 feet I suddenly hear some bizarre noises coming from the passenger side of the motor. It sounded almost like a rushing water or “springee” sound. It was not sharp enough to sound like an engine ping… the motor was knocking but perhaps in an aircraft engine it sounds different than a car. I immediately turned back to KBDR and made a precautionary landing to recheck the plane. After returning to the run up ramp, I removed the engine top bonnet and made a thorough inspection of the motor. Not leaks, loose wires or other abnormalities were noted. I closed up the bonnet and started the plane up and performed a run up again. All was normal so I again departed. This time the plane seemed to run fine and I proceeded on a 1.25 hour flight to KHYA. Once briefly during the flight I heard the strange noise again…but only very briefly. No indicator lamps came on. I landed without incident at KHYA.
The next day at approximately noon I came back to KHYA to fly home to KBDR. No pre heat was required as it was 45 degrees outside. The plane started up but was not running right and appeared to be missing as it was running rough and the yellow FADEC came on. I allowed it to run briefly to warm it up then shut it down completely to clear the FADEC system. . I performed the same process 3 times with the same result. Finally on the 4th re-start the engine ran fine and sounded normal. I caulked it up to perhaps another sticking valve…as I had suffered from one (#2) back in October which was fixed during the annual. I then taxied to the run up pad and the run up proceeded normally with no warn lights or bad indications. I then departed KHYA and climbed normally to 4500 feet. When about 9 miles from KHYA the yellow FADEC warn light cam on…then 30 seconds later the RED warn light came on.
I immediately turned back to KHYA and made a normal landing despite the warn light. After taxiing back to the FBO I performed checks on the system as follows:
-The RPM indications vis-à-vis the throttle position appeared normal
-The FADEC A & B toggles when thrown did not result in any abnormal engine running and behaved normally to the run up protocol.
-The LEFT ignition switch position did not result in the usual 50 RPM drop as usual…and the RPM did not change but the engine ran fine
-The RIGHT ignition position when engaged resulted in the immediate dying of the engine…in this position the engine would die completely.
I then managed to procure a laptop PC and was able to load it with the FADEC Power Link software. I then used the FADEC software to begin a diagnostic test of the system. I did not get very far and the system never proceeded past the non running test gathering FADEC information prior to an engine start up. When it failed to complete that portion of the test I hit abort and the software stated a “Controller Software” Failure. I did start the plane up and use the Power Link software to monitor the engine readings and all appeared normal except for FADEC Caution and Warn lights.
I removed the EDI flight info storage chip and downloaded the files for analysis by TCM.
Conclusions / Best Guesses:
My best guess is that one of the ECU’s failed rather than the speed sensor as the PPM indications were normal. Perhaps it might also be the “software” if any in the ECU…perhaps it was corrupted if indeed there is any loadable software in these units?? Not sure.
I will be sending the EDI files to TCM to see if they indicate what the fault could be. I suppose it could be a bad wiring harness connection but this seems doubtful due to the sudden nature of this happening.

Post Mortem / Next steps:

TCM confirmed my diagnosis as correct…ECU #2 on the pilots side had failed. Removed unit and sent it to TCM to confirm in the lab it had failed. TCM upon receipt tested the unit in the lab and confirmed it had failed. Ordered a new unit and Installed new #2 ECU…..engine still ran badly as before. Ran FADEC real time diagnostics and it said that both Cylinder 1 & 3 channels had been disabled. TCM’s analysis of EDI data indicates that Channel A is being blocked by an “external” factor…most likely a bad ignition switch. This is why in the RIGHT ignition position the motor dies as Channel A is supposed to be working but isn’t. Installed a new ignition switch to no effect. Tested old ignition switch with an OHM meter and it functions as it should…so put the old switch back in.
Now moved on to the wiring harness. Removed firewall pin connectors J5 & J6. Tested enable switch pins J & K per M-22 manual. All readings were normal in R-L-Both positions so wiring fault is not inside the cockpit. Removed both ECU’s and tested enable pins #21 & 37 on both ECU connectors P1 & P2. No ground faults were detected. Conclusion is no ground faults detected between ignition switch and ECU’s so wiring harness is 100% OK. What now??

Selected Notes from email to Liberty on April 4, 2014:
Paul / Jason...

First let me thank you for trying to help me on my FADEC issues...I know Jason is working on it (as he told me so today).....let me summarize what has transpired over last month very briefly:

During my fateful flight to Hyannis March 7th.....EGT 3 and CHT 3 channels were dropping out in ECU 2.
In my aborted flight home on March 8th...these channels did not drop out....for some reason ....but channel A was turned off. I removed the EDI data card and sent the files to TCM. They came back a week later and said ECU 2 had failed. I removed the ECU 2 a week later and sent it in to TCM. They bench tested it and confirmed it had failed so I ordered a new one at $2200. I installed it on March 27 but no change in plane operation was noted. It died in the right ignition switch position due to Channel A being turned off for some reason. This was also the case in my March 8th flight in EDI records as they could see channel A had been turned off.

TCM logically thought that perhaps the ignition switch had failed and grounded out Channel A. It was a logical guess but today’s install of a new switch made no that was not the problem. Tonight I checked the old ignition switches operation with an Ohm meter and its functioning as it should. Tomorrow I will put the old switch back in the plane as it was not the problem.

I am wondering if it could also be some sort of an internal short in ECU 1 or something wrong in the speed sensor again. The cockpit screen shows the correct RPM...but the EDI data files during my March 7th flight showed a cruise at 2000-2100 when I know it was more like 2600 RPM..... I mentioned this to TCM and they felt the EDI RPM discrepancy was most likely due to the failing ECU2...I can't argue with them as the last time I had the SSA failure, the cockpit RPM shown was way low and wrong. This time that isn't true....only the EDI data file RPM is a bit low.
It appears that Channel A is being blocked in cylinder 1 & 3…and both ECU’s….so the problem may be a short to ground between ignition switch and where ever it branches to both ECU’s. So far I have not been able to ID where this short to ground may be located.

The above conclusion was wrong as our wiring checks found no faults. A full wiring harness check under the plane was also performed. No chaffs or rubbing were noted anywhere.

TCM is currently bench testing both the new ECU #2 they sent me as well as the older ECU I sent them both back for simultaneous testing. Results of tests to be learned on Monday April 21.

Update April 23:

TCM confirmed that ECU #1 has also failed on Channel A…so both ECU’s failed on Channel A. What caused both to fail is unknown but it could have been due to the sporadic grounding of the right ignition switch contact against the other unused contact or something else.

We installed the new ECU’s and ran the FADEC software and all passed fine. Plane fixed!
Post Reply